Issue with Enjin Platform Account Management
Incident Report for Enjin
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 15:05 UTC
Identified
We are aware of an issue that is preventing the creation of new accounts on the Enjin Platform, as well as resetting passwords.
Posted Apr 09, 2024 - 08:42 UTC
This incident affected: Platform (Enjin Mainnet, Enjin Canary).